Create an EasyBuilder Pro Project

3. Create an EasyBuilder Pro

Project

This chapter explains the basic steps to create an EasyBuilder Pro project.
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3.1. Overview

The following is the process of creating a project.
1. Create a new project file.

2. Save and compile the project file.

3. Run On-line or Off-line simulation.

4. Download the project file to HMI.

The following describes each process.

E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
3.2. Create a New Project File

1. Launch EasyBuilder Pro and open a new project file.
2. Select a model and select [Use template] check box.

‘ O New  New Project

‘ i 7?“" | Model: | 4 @B iPSeries
MT6051iP (480 x 272)
MT8051iP (480 x 272)
MT6071iP/MT8071iP (800 x 480)
MT6103iP (1024 x 600)
MT8102iP (1024 x 600)
MT6102iQ (1024 x 600)

4 @ eMT Series
€MT3070 (800 x 480)

£eMT3105 (800 x 600)

eMT3120/eMT3150 (1024 x 768)
4 @ iE Series
MTB8050iE (480 x 272)
MT6070iE (800 x 480)
MT6071iE (800 x 480)
MT8070iE/MT8100iE (800 x 480)
MT8071iE/MT8101iE (800 x 480)
MT8073iE (800 x 480)

mn

[¥] Use template (template_800x600.emtp)

eMT3105

Orientation :

[ Portrait

[Uncompress Pche:t] I.L, Demo Prc}e(tJ

3. Click [New] button in the Device tab and select a device.
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.
System Parameter Settings 3
| PrinterBackupServer |  TimeSyne/DST | eMeil | Recipes |  Cellular Data Network
Device | Model | Gemeral | SystemSetting | Security | Non-ASCIIFonts | Extended Memory
Device list : What's my IP ?
Name Location  Device type Interface IIF Protocol

(3 Local HMI Local HMI lLocal  [em73105(800..[- |- |

< | m »

[ New... J [ Delete ] [ Security... ]

4. Configure parameters.

Device Properties

MName :  Mitsubishi FX0S/FXON/FX1S/FX1N/FX2

) HMI @ PLC
PLC type : | Mitsubishi FEOS/FEON/FE 1S/FE LN/FH2 |

IV.1.4U, MITSUBISHI_FXOM.e30

PLCIF : [R5485 4W -

* Support communications between HMI and PLC in pass-through mode
* Set LW-9903 to 2 to enhance the speed of download/upload PLC program in pass-through mode

COM : [COM1 (9600,E,7,1) Settings...

PLC default station no. : g

[] Default station no. use station no. variable

[7] Use broadcast command

Interval of block pack (words) :

Max. read-command size (words) @ |32

Max. write-command size (words) : |22

[ OK ] l Cancel
5. A new device is added to the [Device List].
“:System Parameter Settings ==
| Printe/Backup Server I Time Sync /DST I e-Mail I Recipes I Cellular Data Network
Device | Model | Genersl | SystemSetting | Security | Non-ASCIIFonts | Extended Memory

Device list : What's my IP ?

No. Name Location Device type Interface I/F Protocol
] Local HMI Local eMT3105 (800 -

s I o = T e

6. Create an object, for example, a Toggle Switch, and then set the address.
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7.

"New Toggle Switch/Bit Lamp Object ==
General | Security | Shape | Label |

Comment :

~) Bit Lamp @ Toggle Switch

[V] ReadMWrite use different addresses

Read address
PLC: [Mimbi.shi FEOS/FEONFEISFELINFELZ v] Settings...
Address : [X v] a T
[ Invert signal
Write address :
PLC: [Miwubishi FEOSFEONFEISFEINFLZ v] Settings...
Address : [y v} 0 \
[} Write when button is released
Attribute

Place the object in the edit window. A project is now created.

File B &= « + ; JEEUEE Project  Object  Data/History View  Tool - 8 X A

- P = = 123 @R |« . : jobeDev. ~|5 -

5 e AD S AamE 5 i ; £dobebevanagan ™ |3 $1|s2 s3 s41
= 00 aE-EEE- AA T A-L

Paste e, s i, = g & " B L L2 13 L]t

Clipboard Editing Object Arrange Font State/Language

Windows v X 4q 10 - WINDOW_010 x >

Object list ) L@ @@ aedoe @ cooe @ oe B,
3 : Fast Selection 5
4 : Common Window @
5:PLC Response
6 : HMI Connection

- 7 : Password Restriction
8 : Storage Space Insufficient

i 9:Backup

1 #10 : WINDOW_010

)

m

2 [

L4 x
= i | ‘

[Address | windows [Web ‘

-
o

[ poo poo |ioo |

L R R O O Y R R K R R RN

[ EasyBuilder Pro - EBProject? - [10 - WINDOW_010] =

3.3. Save and Compile the Project File

1.
2.

[\& WEINTEK

In EasyBuilder Pro toolbar click [File] » [Save] to save the .emtp file.

In EasyBuilder Pro toolbar click [Project] » [Compile] to compile .emtp file as .exob file,

which could be downloaded to HMI. This also checks if the project can run correctly.

EasyBuilder Pro V6.05.01
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0 Note

B For cMT Series models, the project file extension is .cmtp, and the compiled file extension

is .cxob.

3. To use multiple languages, all languages must be configured in Label Tag Library first.
When downloading the project to HMI, select the needed languages only. A successful

compilation is shown in the following figure.

Compiling @I
Project name : C:\Users\user\Desktop\EMTP2.emtp
EXOB file name : C:\Users\user\Desktop\EMTP2.exob
EXO0B password : (used in decompiler) [l Decompilation is prohibired
Select the languages used on the HMI
Startup language after redownloading the project : |Language 1 -
[#] Language 1 [#]Language 2 [#]Language 3 [¥#]Language 4 [¥lLanguage 5 (¥ Language 6
Language 7 [¥|Language 8 Language 9 Language 10 Language 11 Language 12
Language 13 Language 14 Language 15 Language 16 Language 17 Language 18
Language 19 Language 20 Language 21 Language 22 Language 23 Language 24
Mote : A maximum of 8 lBnguages can be selected simultaneously.
Double click error messages to modify the attributes of relative objects !

3.4. Run On-Line or Off-Line Simulation
F!I!l!
'_x

any device.

Fm

>

Off-line simulation: Simulate project operation on PC without the need for connecting

On-line simulation: Simulate project operation on PC without downloading the project

to HMI. The PLC is connected to PC, please set correct parameters.

0 Note

B When using On-line Simulation on PC, if the target device is the PLC directly connected to

PC, there is a 10-minute simulation limit.

3.5. cMT Viewer

This program connects to cMT Series models via network. To run this program, execute

I__| WE!NTEK
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cMTViewer.exe under installation directory. Or, in EasyBuilder Pro toolbar, click [Tools] » [cMT
Viewer].
E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
E MT Viewer [=[E] =]

2017-02-09 19:21:24

3.6. Download the Project File to HMI

The following explains four ways to download the project file to HMI.

@ Note

B For cMT-SVR, only the way described in 3.6.1 is available.
B When download project file to HMI using mini USB cable, please do not connect PLC
simultaneously, in order to avoid noise from PLC interfering with HMI.

El Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
3.6.1. Configure in EasyBuilder Pro

1. In EasyBuilder Pro toolbar, click [Project] » [Download]. Make sure that all the settings are
correct.
2. Select [Ethernet], set password and HMI IP.

EWE!NTEK EasyBuilder Pro V6.05.01
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1P 192.168.1.100 -

Download @
(@ Ethernet () USB cable Password/Port no. of download/upload :
4 7 P HMI Name I

W hat's ey IF 7
Font files
Runtime * Mecessary if update runtime or execute download first time.
ry it up
Use user-defined startup screen
File location :
Use system settings file =
Synchronize HMI clock with PC
Delete existing user accounts, e-Mail contacts and SMTP settings
9 9
[ Delete user-defined startup screen
[¥] Reset recipe |#] Reset event log |¥] Reset data sampling
[¥] Reset recipe database [#] Reset operation log [ Reset string table

[/] Reboot HMI after download
[] Automatically using current settings to download after compiling

Setting Description
Font files Download the font used in the project to HMI.
Runtime

Select the check box to update the HMI kernel
programs. If this is the first time downloading file or
EasyBuilder Pro version is updated, please download

the firmware before downloading files to HMI.

EasyAccess 2.0

Download EasyAccess 2.0 driver to HMI. (This option
is available only for MT8000iE models. For other
models, EasyAccess 2.0 will be automatically

downloaded.)

Use user-defined
startup screen

Download the selected .bmp picture to HMI as the

startup screen.

Use system settings
file

Download the system settings file to update

hardware settings.

Synchronize HMI
clock with PC

Synchronize HMI time with PC time when

downloading project file.

Delete existing user
accounts, e-Mail
contacts and SMTP
settings

Select the check box to delete existing user
accounts, e-Mail contacts or SMTP settings before

downloading the project. This setting is only

L—| WE!NTEK
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effective when one of the following settings is

enabled:

1. [System Parameters] » [Security] » [Enhanced
security mode] » [Use existing user accounts on
HMI first (if existed), Othrewise, use settings
below].

2. [System Parameter s] » [e-Mail] » [Use existing
user accounts on HMI first (if existed),

Othrewise, use settings below].

Reset recipe/

event log/

data sampling/ _ .

recipe database/ The selected files will be erased before
operation log/ downloading.

string table/
user-defined
startup screen

Reboot HMI after HMI will reboot after the downloading process is
download

done.

Automatically
using current
settings to to the latest target HMI. The way to enable this
download after
compiling

The system will compile the project and download it

function is described in the following part.

[Automatically using current settings to download after compiling]

If this check box is selected, EasyBuilder Pro will compile the project and download it to the
latest target HMI.

1. In EasyBuilder Pro toolbar, click [File] » [Preferences].

2. Select [Automatic save and compile when download and simulate] check box.

I__| WE'NTEK EasyBuilder Pro V6.05.01
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Preference
Project
Dopiy [¥] Automatically save and compile the project when download and simulate
Grid [7] Generate backup of project file before save
Library [] Automatically make used pictures and shapes into the project library

[] save AutoRecover information

[ OK J [ Cancel

3. In EasyBuilder Pro toolbar, click [Save] and then [Download].

4. In the dialog box, select [Automatically using current settings to download after compiling]
check box.

5. Click [Download].

6. When finished, next time when [Download] is clicked, EasyBuilder Pro will automatically

compile and download the project to the latest target HMI.
3.6.2. Use HMI Name

1. Go to [System settings] on HMI and then set HMI name first.

.Systern settings

Netwcrk‘ Time,fDate" Securit  HMI mame¥eﬁing\gg\

HMI namel

i Cancel | | Apply |iok <!
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2. On PG, select the HMI name and start downloading. To use [Search], enter the HMI nhame

first to search for the HMI. [Search all] searches for all HMIs in the same subnet network.

[V|Runtime *Necessary if update runtime or execute download first time.

[ Use user-defined startup screen

[ Use system settings file

[¥] synchronize HMI clock with PC

[ Delete user-defined startup screen
[7|Reset recipe
[7] Reset recipe database

[V|Reset event log
[V Reset operation log

[¥]Reboot HMI after download
[] Automatically using current settings to download after compiling

Download (==
@ Ethernet Password/Port no. of download/upload :
4 /. IP/ HMIName 3
T v /
HMI: ie7 v
Search All
[Z]Font files [V] Use EasyAccess 2.0 What's sy IP?

[¥] Reset data sampling
[V]Reset string table

I__| WE!NTEK
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3.6.3. Use USB cable

Download (==

@) USB cable Password : | Settings...

|7 Font files
[V|Runtime *Necessary if update runtime or execute download first time.

[ Use user-defined startup screen

[ Use system settings file

[ Delete user-defined startup screen
[7]Reset recipe [V|Reset event log (V] Reset data sampling
[] Reset recipe database [7|Reset operation log [V|Reset string table

[#]Reboot HMI after download

[~ Automatically using current settings to download after compiling

| Download Stop Exit

Select USB cable to download project to HMI. The way of setting is same as “3.6.1 Configure in
EasyBuilder Pro”. Before downloading via USB cable, please make sure the USB driver is

installed. Go to [Computer Management] » [Device Manager] to check if USB driver is installed.

If it is not installed, please refer to to install manually.

3.6.4. Use USB Drive or SD Card

The following explains how to download project file by using USB drive or SD card.
1.  On EasyBuilder Pro toolbar click [Project] » [Build for SD card / USB disk download].

Browse for the project file and then click [Build], the file for download will be generated in
the connected external device.
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USB Disk/CF Card/SD Card Data ==

Select the folder to save download data :

)

Use system setting (OS5 version 20131106 or later supports only)
System setting file location =

’ Build ] l System Settings...
2. Insert an external device to HMI.
3. Select [Download] on HMI and enter password.
Download/Upload
— Pownioad settngs [
Upload Password: ||
Restart project and exit ‘
¥ Download project files
Load System Setting |7 Download history files
Cancel l_ Clear history files
Stop after download/upload . Cancel
Time remaining 4

4. After password is confirmed, it will show the directories in the external device. (pccard: SD
Card; usbdisk: USB Drive)

pick abirectory P4
Directory: Jusbdisle/disk_a_1

=¥ pecard
usbdisk

oK /‘r Cancel

5. Select the directory that contains project, and then click [OK] to start downloading.

I__| WE'NTEK EasyBuilder Pro V6.05.01
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@ Note

B Please select the parent directory of the generated files when downloading. For the
structure above, please select disk_a_1, not mt8000ie.

B You may click [System Settings] to save the hardware settings configured in EasyBuilder
Pro into SD card or USB disk, and then download the settings file to HMI. See “4 Hardware
Settings” for more information.

E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.

3.7. Upload the Project File from HMI

1. On EasyBuilder Pro toolbar click [File] » [Upload].
2. Set HMI IP, HMI model, project location and project name, and then click [Upload].
Upload @

@ Ethernet 71 USB cable Password/Port no. of download/upload :

4 P Name 2
IP: 192.168.1.100 -
What's oy [P 2
HMI model : | eMT3070 >
Project location : C:\EMTP1.exob

v
H
[

Upload
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