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26.1. Overview 

EasyPrinter is a Win32 application and can only run on MS Windows 7 SP1 / 8 / 10. It enables 

HMI to output screen hardcopies to a remote PC via Ethernet. The following explains how to 

use EasyPrinter. 

 

Here are some advantages of using EasyPrinter: 

 EasyPrinter provides two modes of hardcopy output: [Print Out] and [Save to File]. Users 

can use either or both modes. 

 Since EasyPrinter runs on MS Windows system, it supports most of the printers available 

on the market. 

 Multiple HMIs can share one printer so users don’t have to prepare printers for each HMI. 

 

Additionally, EasyPrinter can also be a backup server. Users can use Backup objects on HMI to 

copy history files such as Data Sampling records and Event Log to a remote PC via Ethernet. 

Please see the following illustration: 
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26.2. Using EasyPrinter as a Printer Server 

 

Users can make screen hardcopies with a Function Key object. The hardcopies will be 

transferred to the Remote Printer Server via Ethernet and then printed out. 

 Setup Procedure in EasyPrinter 26.2.1.

In EasyPrinter’s main menu, select [Options] » [Settings] and the following dialog box appears: 

 

1. Select [General] on the left hand side. 

2. In [Server], set [Port number of the server socket] to “8005”, *User name+ to “admin” and 

*Password+ to “111111”. (These are default values.) 

3. In [Naming Convention for HMI Folder], select [Use IP address] and enter “IP_” in the 

[Prefix] field. 

4. In [Properties], select [Minimize to system tray] check box. Select [Start EasyPrinter when I 

start Windows] if necessary. 

 

Set the print out location. 
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1. Select [Hardcopy] on the left hand side. 

2. Under [Output] select [Print out to] and choose a printer as the output device for screen 

hardcopies. (The printer shown in the image above is an example; please select an actual 

printer located in your network environment.) 

3. Select [Save to files in:] and browse for the directory to save the hardcopy file. 

4. Click [OK] to confirm the settings. 

5. In EasyPrinter main menu select [File] » [Enable Output] to output any incoming print 

request. 

 Setup Procedure in EasyBuilder Pro 26.2.2.

The setting procedure of EasyPrinter in EasyBuilder Pro: 

1. Open a new project or an existing project in EasyBuilder Pro. 

2. In EasyBuilder Pro main menu select [Home] » [System Parameters] » [Printer/Backup 

Server] and select [Use Remote Printer/Backup Server] check box. 
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3. Under [Output settings] set appropriate values for left / top / right / bottom margins. (The 

margins are all set to 15mm in the example.) 

4. Under [Communication settings] fill in the [IP address] of the printer server according to 

the settings in EasyPrinter. Set [Port] to “8005”, *User name+ to “admin” and *Password+ to 

“111111”. 

5. Click [OK]. 

6. In EasyBuilder Pro main menu select [Objects] » [Button], select [Function Key], select 

[Screen hardcopy] and set [Printer] to [MT Remote Printer/Backup Server]. 

 

7. Place the Function Key object in the common window (window no. 4) so that screen 

hardcopies can be captured anytime when needed. 

8. Compile and download the project to HMI. Press the Function Key object on the screen to 

make a screen hardcopy. 

Note 

 A PLC Control object can also be used to make screen hardcopies. 
 Alarm information cannot be printed via EasyPrinter. 
 EasyPrinter can only communicate with HMI via Ethernet. Please check that the HMI has 

appropriate network settings. 
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26.3. Using EasyPrinter as a Backup Sever 

 

Backup objects can upload historical data and Operation Log to remote backup server. 

 

 Setup Procedure in EasyPrinter 26.3.1.

In EasyPrinter’s main menu, select [Objects] » [Settings] and the following dialog box will 

appear: 

 

1. Select [General] on the left hand side. 

2. Under [Server] set [Port number of the server socket] to “8005”, *User name+ to “admin” 

and *Password+ to “111111”. (These are default values.) 

3. Under [Naming Convention for HMI Folder] select [Use IP address] and enter “IP_” in the 

[Prefix] field. 

4. Under [Properties] select [Minimize to system tray]. Select [Start EasyPrinter when I start 
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Windows] if necessary. 

 

Set the backup location. 

  

1. Select [Backup] on the left. 

2. Under [Output] click the  button to browse and select a storage directory of the 

incoming history files. 

3. Click [OK] to confirm the settings. 

4. In the main menu, select [File] » [Enable Output] to backup data in the selected directory. 

 Setup Procedure in EasyBuilder Pro 26.3.2.

The setup procedure of EasyPrinter in EasyBuilder Pro: 

1. Open a new project or an existing project in EasyBuilder Pro. 

2. In EasyBuilder Pro’s main menu, select [Home] » [System Parameters] » [Printer/Backup 

Server] and select the [Use Remote Printer/Backup Server] check box. 
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3. Under [Communication settings] fill in the [IP address] of the printer server according to 

the settings in EasyPrinter. Set the [Port] to “8005”, *User name+ to “admin” and 

*Password+ to “111111”. (Note: These are default values.) 

4. Click [OK]. 

 

Create a Backup object. 

1. In EasyBuilder Pro’s main menu, select [Data/History] » [Backup] and the following dialog 

box appears: 
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2. Under [Source] select [Historical event log] (or [RW], [RW_A] if needed.) 

3. Under [Backup position] select [Remote printer/backup server]. 

4. Under [Range] select [Today] and [All] (or other options if needed.) 

5. Under [Trigger] select [Touch trigger]. 

6. Click [OK]. 

7. Place the [Backup] object in the common window (window no. 4), and users will be able 

to make backups anytime when needed. 

8. Compile and download the project to HMI. Press the Backup object on the screen to make 

a backup of the history data. 

Note 

 The Backup object can also be triggered by a bit address. 

 Users can arrange a Scheduler object, which turns a bit ON at the end of a week, to trigger 

the Backup object to automatically back up all history data. 
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26.4. EasyPrinter Operation Guide 

The following introduces the interface and operation of EasyPrinter. 

 EasyPrinter Managing Window 26.4.1.

EasyPrinter main menu is divided into 5 parts as shown in the following figure: 

 

Area Name Description 

1 Job List Lists all incoming tasks, such as screen 

hardcopy and backup requests. 

2 Download Progress Shows the download progress of incoming 

requests. 

3 Preview Shows the preview image of the screen 

hardcopy task selected from [Job List]. 

4 Properties Shows the information about the task 

selected from [Job List]. 

5 Logger Shows the time and message information of 

events such as incoming request, incorrect 

password, etc. 
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 Operation Guide 26.4.2.

The following describes the function of EasyPrinter menu items. 

 

Menu Description 

File Enable Output 

If selected, EasyPrinter processes the tasks one by one, 

otherwise, EasyPrinter stores the tasks in memory. 

Edit Edit 

Edits screen hardcopy by setting [Orientation], [Scaling] and 

[Margins]. 

Delete 

Deletes the selected tasks permanently. 

Select All 

Selects all tasks from [Job List]. 

View Properties Bar 

Shows or hide the Property Window. 

Preview Bar 

Shows or hide the Preview Window. 

Download Bar 

In [Download Progress] Window, the mode to display download 

progress can be set by clicking the header of the [progress] 

column as shown in the following figure: 

 
Logger Bar 

EasyPrinter can reserve up to 10,000 messages in Message 

Window. If a new message comes in, the oldest message will be 

deleted. 

Options Please see the following page. 

 

Note 

 EasyPrinter can only reserve up to 128 MB of task data in memory. If the memory is full, 

any request coming in afterwards will be rejected. Users must either operate [Enable 

Output] or delete some tasks to make room for new tasks. 
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 The backup task is not editable. 

 [Edit] is available only when a task is selected. 

 [Delete] is available when at least one task is selected. 

 

The following is the detail for [Options] » [Settings] 

 In General Tab: 

 

Setting Description 

Server Port number of the server socket 

Sets the Ethernet port number to connect the HMI. Range: 1 ~ 

65535. Default: 8005. 

User name / Password 

Sets the user name and password to let only authorized HMIs send 

requests to EasyPrinter. 

Naming 

Convention 

for HMI 

Folder 

EasyPrinter uses different folders to store files (e.g. hardcopy 

bitmap files, backup files) from different HMI. There are two ways 

to name the folders: 

Use IP address 

EasyPrinter names the folder as [Prefix] + [IP address] after the 

HMI at this IP address sends request. 
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Use HMI name 

EasyPrinter names the folder in [Prefix] + [HMI name] after the 

HMI this name indicates sends request. 

Properties Minimize to system tray 

If this check box is selected, the EasyPrinter shortcut icon will be 

placed in the system tray in PC. Double click the on icon in system 

tray to open EasyPrinter. 

Detailed message 

Select this check box to display more detailed messages about 

events in the message window. 

Start EasyPrinter when I start Windows 

Select this check box to automatically run EasyPrinter when 

Windows starts. 

 

 In Hardcopy Tab: 
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Setting Description 

Output Print out to 

EasyPrinter prints out the hardcopy result with the specified 

printers. 

Save to files in 

EasyPrinter converts the hardcopy result into a bitmap file and 

saves it in the specified directory. The bitmap files are found at: 

[Specified Path] \ [HMI Folder] \ yymmdd_hhmm.bmp 

For example, when a hardcopy request is given at 17:35:00, 

12/Jan/2009, the bitmap file will be named “090112_1735.bmp”. 

And if there is another bitmap file generated within the same 

minute, it will be named “090112_1735_01.bmp” and so on. 

 

 In Backup Tab: 

 

Setting Description 

Output Backup files in: 

EasyPrinter stores the backup files to the specified 

path. 

The upper directory is the same: 

[Specified Path] \ [HMI Name] or [IP address] 

The lower directory:  

 For Event Log files:  

\ eventlog\ EL_yyyymmdd.evt 

 For Data Sampling files:  

\ datalog \ [File name of the Data Sampling] \ 

yyyymmdd.dtl 
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 For Recipe files: 

\ recipe \ recipe.rcp or recipe_a.rcp 

 For Recipe Database:  

\ recipe \ recipe.db 

 For Operation Log: 

\ operationlog\ operationlog.db 

Convert Batch File Select [Enable] to convert the selected history file 

to .csv or .xls (Excel) format of Convert Batch Files. 

Note 

 System registers LW-9032 to LW-9039 can be used to specify HMI name. 

 When closing EasyPrinter, the following dialog will appear. 

 

26.5. Convert Batch File 

EasyPrinter provides a conversion tool to convert the uploaded Data Sampling and Event Log 

history files to .csv files automatically. To do so, please select [Enable] under [Convert Batch 

File] to make EasyPrinter convert the history files. 

In the following illustration, the conversion is actually executed by EasyConverter. EasyPrinter 

simply follows the criteria in Convert Batch File and activates EasyConverter with proper 

arguments to achieve the conversion. 

 

Note 

 EasyConverter is another Win32 application that converts history data into .csv or MS 
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Excel .xls files. Users can find it in the EasyBuilder Pro installation directory. 

 Users requesting this function must ensure EasyPrinter and EasyConverter are placed in 

the same directory. 

 The Default Value of Convert Batch File 26.5.1.

The following is the default Convert Batch File: convert2csv.def 

Listing 1. Default Convert Batch File 

1: "dtl", "EasyConverter /c $( Pathname)" 

2: "evt", "EasyConverter /c $( Pathname)" 

There are two lines in the file. Each line has two arguments separated by a comma and forms a 

criterion of how to process a specific type of files. The first argument stands for the extension 

name of the file type to be processed. The second argument stands for the command to be 

executed in console mode. Please note that “$(Pathname)” is a key word to inform EasyPrinter 

to replace it with the real name of the converted backup file. For example, if a Data Sampling 

history file named 20090112.dtl is uploaded and stored, EasyPrinter will send out the following 

command to a console window: 

 

1: EasyConverter /c 20090112.dtl 

 

A file named 20090112.csv is created. 

The criteria of the default Convert Batch File: 

1. Convert all Data Sampling history files (.dtl) into .csv files. 

2. Convert all Event Log history files (.evt) into .csv files. 

Note 

 “$(Pathname)” in the second argument stands for the full path name of the file. In the 

previous case, EasyPrinter replaces it with: 

[Specified Path] \ [HMI Folder] \ [datalog] \ [Folder name of the Data-Sampling object] \ 

20090112.dtl 

 EasyPrinter interprets the Convert Batch File in line basis, that is, each line forms a 

criterion. 

 Any two arguments should be separated by a comma. 

 Every argument should be put in double quotes. 

 Do not put any comma inside an argument. 

 Supported parameters for batch file: $(PathName), $(HmiName), and $(IP) which stand 

for file path, HMI name, and HMI IP address. 

 When [Start EasyPrinter when I start Windows] option is selected, please add in the file 

path where EasyConverter is placed, which is usually the EBPro installation directory in 
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your PC, as shown below. 

1: "dtl", "C:\EBPro\EasyConverter /c $(Pathname)" 

2: "evt", "C:\EBPro\EasyConverter /c $(Pathname)" 

 

 For more information, see “25 Easy Converter”. 

 Specialized Criteria 26.5.2.

The specialized criterion are needed when: 

 Upload file to a specific HMI, see listing 2. 

 Identify the HMI by HMI name, see listing 3. 

 Process differently to different Data Sampling, see listing 4. 

(This can only be used for Data Sampling file with the file name “voltage”.) 

The 3rd argument (“*”) indicates this criterion accepts the Data Sampling files that meet the 

criterion from any HMI. Users can also change the 3rd argument to “192.168.1.26”, 

“192.168.1.*”, or HMI name, etc. for narrowing the range of the target HMI. 

 

Listing 2. Specialized Criterion for the HMI IP: 192.168.1.26 

1: "dtl", "EasyConverter /c $(Pathname)", "192.168.1.26" 

 

Listing 3. Specialized Criterion for HMI name: Weintek_01 

1: "dtl", "EasyConverter /c $(Pathname)", "Weintek_01" 

 

Listing 4. Specialized Creterion for Data Sampling file name: Voltage 

1: "dtl", "EasyConverter /s Voltage.lgs $(Pathname)", "*", "Voltage" 

 The Format of a Convert Batch File 26.5.3.

The following explains the arguments in a criterion. 

File Type Command (line) HMI IP / Name Condition 1 Condition 2 

 File Type 

This argument specifies the extension name of the uploaded file in this criterion.  

(e.g. “.dtl” for Data Sampling history files, “.evt” for Event Log history files) 

 Command (line) 

The command EasyPrinter sends to a console window if the uploaded file meets the 

criterion. 

 HMI IP / Name 

This argument specifies the HMI that meets the criterion. 

 Condition 1 

This argument specifies the folder name of the Data Sampling files that meet the criterion. 
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This is not effective to other format of files. 

 Condition 2 

Not used (Reserved for future use). 

 The Order of Examining Criterion 26.5.4.

EasyPrinter examines criterion in descending order every time a file is uploaded. Once the file 

meets a criterion, it stops the examination and starts over for the next file. Therefore, users 

should place the criterion with a wider range downward in the Convert Batch File and place the 

more specific criteria upward. For example: 

"evt", "EasyConverter /c $(Pathname)" 

"dtl", "EasyConverter /c $(Pathname)" 

"dtl", "EasyConverter /c $(Pathname)", "192.168.1.26" 

"dtl", "EasyConverter /c $(Pathname)", "my_HMI_01" 

"dtl", "EasyConverter /c $(Pathname)", "my_HMI_02" 

"dtl", "EasyConverter /s Voltage.lgs $(Pathname)", "*", “Voltage" 

 

The correct order of examination would be: (from bottom to top) 

"dtl", "EasyConverter /s Voltage.lgs $(Pathname)", "*", “Voltage" 

"dtl", "EasyConverter /c $(Pathname)", "my_HMI_02" 

"dtl", "EasyConverter /c $(Pathname)", "my_HMI_01" 

"dtl", "EasyConverter /c $(Pathname)", "192.168.1.26" 

"dtl", "EasyConverter /c $(Pathname)" 

"evt", "EasyConverter /c $(Pathname)"
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